• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

LISP - Lab 2: Triển khai LISP-to-LISP trên IPv4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LISP - Lab 2: Triển khai LISP-to-LISP trên IPv4

    Trong bài lab số 2 này, ta sẽ học được cách cấu hình LISP cơ bản bằng cách kích hoạt tính năng LISP trên các router xTR. Sau đó khảo sát traffic LISP-to-LISP giữa các điểm đầu cuối (EID) thông qua các router định vị (RLOC).

    Trong bài lab này, chúng ta sẽ sử dụng lại sơ đồ và cấu hình của bài trước. Nếu bạn chưa xem qua bài 1, mời xem lại nó trước khi xem tiếp bài này (Xem bài 1)



    Một số thuật ngữ và viết tắt trong bài:
    • RLOC (Routing Locator): Router định vị
    • EID (Endpoint ID): ID đầu cuối
    • ITR (Ingress Tunnel Router) / ETR (Egress Tunnel Router): Khi một gói tin đi từ host 1 của Site A sẽ vào ITR (Router đóng gói đầu vào) trước, sau đó được chuyển tới ETR (Router mở gói đầu ra) và đến host 2 của Site B.
    • xTR: Router đóng vai trò vừa là ITR, vừa là ETR.
    • MS (Mapping Server): Router ánh xạ địa chỉ
    • MR (Mapping Resolver): Router phân giải tên
    • MSMR (hoặc MS/MR): Router vừa có chức năng là MS, vừa là MR
    Mục tiêu bài lab

    Thông qua bài học này, ta sẽ học được cách để cấu hình LISP cơ bản trên các router xTR và biết được các bước kiểm tra hoạt động của LISP.

    Hướng dẫn


    Bước 1: Cấu hình EID trên router xTR của Site 1 (R112)

    Trong bài lab này, router R112 sẽ chỉ sử dụng cổng Ethernet1/1 để làm RLOC trong LISP (cổng E1/2 sẽ được sử dụng trong các bài lab sau).

    Cấu hình LISP trên router R112:
    Code:
    R112-xTR#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R112-xTR(config)#router lisp
    R112-xTR(config-router-lisp)#
    Tạo một “locator-set” (bộ định vị) cho Site 1, trong interface Ethernet 1/1 là RLOC duy nhất. Ta đặt priority là 1 và weight là 1 cho RLOC này:
    Code:
    R112-xTR(config-router-lisp)#[B][COLOR=#FF0000]locator-set SITE1[/COLOR][/B]
    R112-xTR(config-router-lisp-locator-set)# [B][COLOR=#FF0000]10.0.1.2 priority 1 weight 1[/COLOR][/B]
    R112-xTR(config-router-lisp-locator-set)#exit
    R112-xTR(config-router-lisp)#
    * Cách khác :

    Khi một Site trong LISP có RLOC nhận IP động (như từ giao thức DHCP), ta có thể cấu hình bằng cách chỉ định interface sẽ được làm RLOC thay vì chỉ định IP một cách trực tiếp. Ví dụ:
    Code:
    R112-xTR(config-router-lisp)#[B][COLOR=#FF0000]locator-set SITE1 [/COLOR][/B]
    R112-xTR(config-router-lisp-locator-set)#[B] [COLOR=#FF0000]ipv4-interface Ethernet1/1 priority 1 weight 1 [/COLOR][/B]
    R112-xTR(config-router-lisp-locator-set)#exit
    R112-xTR(config-router-lisp)#
    Trong ví dụ bên trên, interface Ethernet 1/1 sẽ được tự động dùng làm RLOC. Nếu IP trên interface này thay đổi, ví dụ được cấp IP mới thông qua DHCP, xTR sẽ lập tức đăng kí lại IP mới của RLOC với Router ánh xạ địa chỉ (MS – Mapping Server).

    Cấu hình EID prefix là 192.168.1.0/24 cho ETR này trong bản định tuyến (global) mặc định (không sử dụng virtualization instance-id), áp dụng cho Site 1:
    Code:
    R112-xTR(config-router-lisp)#[B][COLOR=#FF0000]eid-table default instance-id 0 [/COLOR][/B]
    R112-xTR(config-router-lisp-eid-table)#[B][COLOR=#FF0000]database-mapping 192.168.1.0/24 locator-set SITE1 [/COLOR][/B]
    R112-xTR(config-router-lisp-eid-table)#exit
    R112-xTR(config-router-lisp)#
    Bật tính năng ITR và ETR của LISP trên router. Chú ý rằng khi dịch vụ bắt đầu, ta sẽ nhận được một thông báo cho biết dịch vụ đã hoạt động.
    Code:
    R112-xTR(config-router-lisp)#[B][COLOR=#FF0000]ipv4 itr [/COLOR][/B]
    R112-xTR(config-router-lisp)#[B][COLOR=#FF0000]ipv4 etr [/COLOR][/B]
    R112-xTR(config-router-lisp)#
    [B][COLOR=#FF0000]*Apr  8 00:53:01.044: %LINEPROTO-5-UPDOWN: Line protocol on Interface LISP0, changed state to up [/COLOR][/B]
    Cấu hình xTR trỏ tới MSMR (R114):
    Code:
    R112-xTR(config-router-lisp)#[COLOR=#FF0000][B]ipv4 itr map-resolver 10.0.100.2 [/B][/COLOR]
    R112-xTR(config-router-lisp)#[COLOR=#FF0000][B]ipv4 etr map-server 10.0.100.2 key SITE1KEY [/B][/COLOR]
    R112-xTR(config-router-lisp)#
    Cuối cùng, kích hoạt cơ chế rloc-probing để router có xác định được các RLOC ở site khác.
    Code:
    R112-xTR(config-router-lisp)#[COLOR=#FF0000][B]loc-reach-algorithm rloc-probing [/B][/COLOR]
    R112-xTR(config-router-lisp)#end
    R112-xTR#
    Router MSMR (R114) đã được cấu hình thông tin các site (Site 1 và Site 2) của LISP ở bài trước. Chuỗi xác thực “SITE1KEY” khi ta cấu hình trên R112 phải trùng với chuỗi xác thực trên R114 thì quá trình đăng kí mới thành công.

    Bước 2:

    Để kiểm tra EID prefix của Site 1 đã được đăng kí hay chưa, ta dùng lệnh show ip lisp database để xem thông tin database của LISP trên R112, chú ý các thông tin output phải trùng khớp với những gì ta đã cấu hình bên trên:
    Code:
    R112-xTR#show ip lisp database
    LISP ETR IPv4 Mapping Database for EID-table default (IID 0), LSBs: 0x1, 1 entries
    
    [B][COLOR=#FF0000]192.168.1.0/24, locator-set SITE1
      Locator   Pri/Wgt  Source     State
      10.0.1.2    1/1    cfg-addr   site-self, reachable[/COLOR][/B]
    R112-xTR#
    Sử dụng lệnh show ip lisp map-cache để xem dữ liệu ban đầu của map-cache trên R112.
    Code:
    R112-xTR#sh ip lisp map-cache  
    LISP IPv4 Mapping Cache for EID-table default (IID 0), 1 entries
     0.0.0.0/0, uptime: 00:08:54, expires: never, via static send map-request  
    Negative cache entry, action: send-map-request
    R112-xTR#
    Điểm ta cần chú ý: Chỉ có default map-cache (luôn luôn hiện diện) bên trong map-cache. Lúc này, Site 1 chưa thể giao tiếp được với các site khác trong LISP. Ngoài default map-cache, không có dòng nào khác. Default map-cache (0.0.0.0/0) có “action” là “send-map-request”, có tác dụng khiến cho router có thể tự động gửi truy vấn tới Router Ánh Xạ để tìm các đích đến khi không tự xác định được.

    Sử dụng lệnh “lig self ipv4” để truy vấn lên Mapping Server tìm EID prefix mà R112 sở hữu:
    Code:
    R112-xTR#lig self ipv4
    Mapping information for EID 192.168.1.0 from 10.0.1.2 with RTT 76 msecs
    [COLOR=#FF0000][B]192.168.1.0/24, uptime: 00:00:00, expires: 23:59:59, via map-reply, self, complete
      Locator   Uptime    State      Pri/Wgt
      10.0.1.2  00:00:00  up, self     1/1[/B][/COLOR]
    Bước này giúp ta biết được R112 đã đăng kí đúng. Nếu R112 không đăng kí đúng, lệnh lig không trả lại EID prefix của site này.

    Lúc này, EID mà R112 sở hữu đã có trong map-cache, ta dùng lệnh lại lệnh “show ip lisp map-cache” để thấy:
    Code:
    R112-xTR#sh ip lisp map-cache  
    LISP IPv4 Mapping Cache for EID-table default (IID 0), 2 entries
    0.0.0.0/0, uptime: 00:16:56, expires: never, via static send map-request  
     Negative cache entry, action: send-map-request
    [B][COLOR=#FF0000]192.168.1.0/24, uptime: 00:01:55, expires: 23:58:09, via map-reply, self, complete  
     Locator   Uptime    State      Pri/Wgt  
     10.0.1.2  00:01:55  up, self     1/1   [/COLOR][/B]
    R112-xTR#
    Thông tin output phải trùng với thông tin đã cấu hình từ trước.

    Chú ý: Sự tồn tại của EID mà R112 sở hữu trong bảng map-cache (local) từ trước không ảnh hưởng đến hoạt động của LISP. Thao tác bên trên giúp bạn hiểu được hoạt động của LISP control plane, cách để biết được một site đã đăng kí thành công hay chưa.

    Sau đây là một ví dụ minh họa cho trường hợp cấu hình Authentication Key bị sai và Site 1 không thể đăng kí được với MSMR. Kết quả sau đây được trả về khi ta dùng lệnh “lig self ipv4” trên xTR 112:
    Code:
    [COLOR=#FF0000]R112-xTR#lig self ipv4
    Mapping information for EID 192.168.1.0 from 10.0.100.2 with RTT 1 msecs
    192.168.1.0/24, uptime: 00:00:00, expires: 00:00:59, via map-reply, self, forward-native  
      [B]Negative[/B] cache entry, action: forward-native
    R112-xTR#[/COLOR]
    Nếu site được đăng kí chính xác (và control plane hoạt động), ta sẽ nhận được kết quả trả về chính xác. Trong trường hợp này, kết quả trả về là “Negative” tức là đã thất bại khi đăng kí. (Còn những cách kiểm tra khác nếu ta có quyền truy cập vào Mapping-Server, sẽ được nhắc đến bên dưới).

    Bước 3: Cấu hình EID cho LISP ở Site 2 (trên R116).

    Trình tự cấu hình tương tự như cấu hình LISP ở Site 1, nhưng khác ở việc chỉ định RLOC và thông tin LISP EID Site 2:
    Code:
    R116-xTR(config)#[COLOR=#FF0000]router lisp [/COLOR]
    R116-xTR(config-router-lisp)#[COLOR=#FF0000]locator-set SITE2 [/COLOR]
    R116-xTR(config-router-lisp-locator-set)#[COLOR=#FF0000]10.0.9.2 priority 1 weight 1 [/COLOR]
    R116-xTR(config-router-lisp-locator-set)#exit
    R116-xTR(config-router-lisp)#[COLOR=#FF0000]eid-table default instance-id 0 [/COLOR]
    R116-xTR(config-router-lisp-eid-table)#[COLOR=#FF0000]database-mapping 192.168.7.0/24 locator-set SITE2 [/COLOR]
    R116-xTR(config-router-lisp-eid-table)#exit
    R116-xTR(config-router-lisp)#[COLOR=#FF0000]ipv4 itr [/COLOR]
    R116-xTR(config-router-lisp)#[COLOR=#FF0000]ipv4 etr[/COLOR]
    R116-xTR(config-router-lisp)#[COLOR=#FF0000]ipv4 itr map-resolver 10.0.100.2 [/COLOR]
    R116-xTR(config-router-lisp)#[COLOR=#FF0000]ipv4 etr map-server 10.0.100.2 key [B]SITE2KEY[/B] [/COLOR]
    R116-xTR(config-router-lisp)#^Z
    R116-xTR#
    MSMR (R114) cũng phải được cấu hình LISP cho site 2 (ở bài lab 1). Authentication key “SITE2KEY” trên R116 phải trùng khớp với thông tin trên MSMR.

    Bước 4: Xác thực thông tin LISP của Site 2

    Dùng lệnh show ip lisp database để kiểm tra trạng thái database của LISP trên R116. Thông tin output phải trùng với thông tin ta đã cấu hình bên trên.
    Code:
    R116-xTR#sh ip lisp database  
    LISP ETR IPv4 Mapping Database for EID-table default (IID 0), LSBs: 0x1, 1 entries
    [COLOR=#FF0000][B]192.168.7.0/24, locator-set SITE2  
      Locator   Pri/Wgt  Source     State  
      10.0.9.2    1/1    cfg-addr   site-self, reachable [/B][/COLOR]
    R116-xTR#
    Dùng lệnh show ip lisp map-cache để xem trạng thái của map-cache của LISP trên R116. Tương tự R112, ta cũng thấy chỉ có dòng default map-cache bên trong và Site 2 chưa thể giao tiếp với site khác.
    Code:
    R116-xTR#sh ip lisp map-cache  
    LISP IPv4 Mapping Cache for EID-table default (IID 0), 1 entries
    0.0.0.0/0, uptime: 00:07:53, expires: never, via static send map-request  
      Negative cache entry, action: send-map-request
    R116-xTR#
    Dùng lệnh “lig self ipv4” để truy vấn đến Mapping Server để tìm EID prefix mà R116 sở hữu. Câu lệnh “lig” (LISP Internet Groper) là một công cụ có thể sử dụng để truy vấn đến Mapping Server của LISP để hỏi EID prefix. Bước này xác nhận rằng R116 đã đăng kí chính xác. Nếu R116 đăng kí sai, lig sẽ không trả về EID prefix của Site này.
    Code:
    R116-xTR#lig self ipv4
    Mapping information for EID 192.168.7.0 from 10.0.9.2 with RTT 0 msecs
    [COLOR=#FF0000][B]192.168.7.0/24, uptime: 00:00:00, expires: 23:59:59, via map-reply, self, complete
       Locator   Uptime    State      Pri/Wgt
       10.0.9.2  00:00:00  up, self     1/1[/B][/COLOR]
    R116-xTR#
    Bước 5

    Dùng “show lisp site detail” trên Mapping-Server (R114) để xem các EID prefix của các Site đã được đăng kí:
    Code:
    R114-MSMR#sh lisp site detail  
    LISP Site Registration Information
    [COLOR=#FF0000][B]Site name: site1 [/B][/COLOR]
    Description: LISP Site 1 - GOLD Lab
    Allowed configured locators: any
    Allowed EID-prefixes:
      [COLOR=#FF0000][B] EID-prefix: 192.168.1.0/24
         First registered:     00:10:54[/B][/COLOR]
         Routing table tag:    0
         Origin:               Configuration
         Merge active:         No
         Proxy reply:          No
         TTL:                  1d00h
         State:                complete
         Registration errors:
            Authentication failures:   0
            Allowed locators mismatch: 0
        [COLOR=#FF0000][B] ETR 10.0.2.2, last registered 00:00:41, no proxy-reply, map-notify[/B][/COLOR]
             TTL 1d00h, no merge, hash-function sha1, nonce 0x954597F5-0x859BF9D1
             state complete, no security-capability
             xTR-ID 0x816B8510-0xBEA35091-0x9D01B036-0xBD9EC071
             site-ID unspecified      
    [COLOR=#FF0000][B]Locator   Local  State      Pri/Wgt      
    10.0.1.2  yes    up           1/1   [/B][/COLOR]
    ---<skip>---
    [COLOR=#FF0000][B]Site name: site2 [/B][/COLOR]
    Description: Site 2 - GOLD Lab
    Allowed configured locators: any
    Allowed EID-prefixes:
      [COLOR=#FF0000][B] EID-prefix: 192.168.7.0/24
         First registered:     00:09:59[/B][/COLOR]
         Routing table tag:    0
         Origin:               Configuration
         Merge active:         No
         Proxy reply:          No
         TTL:                  1d00h
         State:                complete
         Registration errors:
           Authentication failures:   0
           Allowed locators mismatch: 0
        [COLOR=#FF0000][B] ETR 10.0.9.2, last registered 00:00:48, no proxy-reply, map-notify[/B][/COLOR]
             TTL 1d00h, no merge, hash-function sha1, nonce 0xCADCE387-0xFF2B9684
             state complete, no security-capability
             xTR-ID 0x046EC371-0xBC7134B0-0x59DED478-0x067155EA
             site-ID unspecified
    [COLOR=#FF0000][B]Locator   Local  State      Pri/Wgt
    10.0.9.2  yes    up           1/1[/B][/COLOR]
    ---<skip>---
    R114-MSMR#
    Bước 6: Kiểm tra kết nối LISP-to-LISP bằng cách ping từ Site 1 sang Site 2

    Sử dụng tính năng source-ping để ping từ R112 đến R116 (sử dụng các EID loopbacks để làm source và destination address) :
    Code:
    R112-xTR#[COLOR=#FF0000][B]ping 192.168.7.254 source 192.168.1.254 [/B][/COLOR]
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.7.254, timeout is 2 seconds:
    Packet sent with a source address of 192.168.1.254  
    [B][COLOR=#FF0000]..!!!
    Success rate is 60 percent (3/5), round-trip min/avg/max = 1/1/1 ms [/COLOR][/B]
    R112-xTR#
    Hai packet đầu tiên không thành công. Nó chỉ ra rằng map-cache của cả 2 xTR không có thông tin về đích đến. Những packet đầu tiên bị discard bởi R112 và R116 trong khi chờ đợi xây dựng thông tin về map-cache của nhau. Khi quá trình xây dựng thông tin map-cache hoàn tất, các luồng dữ liệu tiếp theo giữa bất kì host nào nằm trong /24 EID prefix sẽ sử dụng lại thông tin đã xây dựng trong map-cache.

    Dùng lệnh “show ip lisp map-cache” trên R112 để xem thông tin mới nằm trong map-cache, đại diện cho Site 2:
    Code:
    R112-xTR#sh ip lisp map-cache  
    LISP IPv4 Mapping Cache for EID-table default (IID 0), 2 entries
     0.0.0.0/0, uptime: 20:03:11, expires: never, via static send map-request
       Negative cache entry, action: send-map-request
     [COLOR=#FF0000][B]192.168.7.0/24, uptime: 20:02:48, expires: 04:43:43, via map-reply, complete
       Locator   Uptime    State      Pri/Wgt
       10.0.9.2  20:02:48  up           1/1[/B][/COLOR]
    R112-xTR#
    Dùng lệnh “show ip lisp map-cache” trên R116 để xem thông tin mới bên trong map-cache, đại diện cho Site 1:
    Code:
    R116-xTR#sh ip lisp map-cache  
    LISP IPv4 Mapping Cache for EID-table default (IID 0), 2 entries
     0.0.0.0/0, uptime: 20:04:35, expires: never, via static send map-request
       Negative cache entry, action: send-map-request
    [COLOR=#FF0000][B]192.168.1.0/24, uptime: 20:04:17, expires: 04:42:36, via map-reply, complete
       Locator   Uptime    State      Pri/Wgt
       10.0.1.2  20:04:17  up           1/1[/B][/COLOR]
    R116-xTR#
    Trên router host 1 (R111), dùng tính năng source-ping lại lần nữa. Lần này không gói tin nào bị drop:
    Code:
    R111-Host1#[COLOR=#FF0000][B]ping 192.168.7.1 source 192.168.1.1 rep 100 [/B][/COLOR]
    Type escape sequence to abort.
    Sending 100, 100-byte ICMP Echos to 192.168.7.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.1.1  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    [COLOR=#FF0000][B]Success rate is 100 percent (100/100), round-trip min/avg/max = 1/1/1 ms [/B][/COLOR]
    R111-Host1#
    Trên xTR R112, dùng lệnh “show ip lisp forwarding eid remote” để kiểm tra xem bao nhiêu LISP packets đã được đóng gói bởi router này và hiển thị các thuộc tính của LISP về cách R112 đóng gói các packet để gửi tới remote EID.
    Code:
    R112-xTR#sh ip lisp forwarding eid remote 192.168.7.1
     Prefix                 Fwd action  Locator status bits
     192.168.7.0/24         encap       0x00000001
      [COLOR=#FF0000][B] packets/bytes     114/11274[/B][/COLOR]
       path list B460082C, flags 0x49, 3 locks, per-destination
       ifnums:
        LISP0(21): 10.0.9.2
       1 path
         path B45CF1C8, path list B460082C, share 1/1, type attached nexthop, for IPv4
         nexthop 10.0.9.2 LISP0, adjacency IP midchain out of LISP0, addr 10.0.9.2 B467E5F8
       1 output chain
       chain[0]:  IP midchain out of LISP0, addr 10.0.9.2 B467E5F8 IP adj out of Ethernet1/2, addr 10.0.2.1 B467E4C8
    R112-xTR#
    Từ router host 1 (R111), dùng tính năng sourced traceroute để xem đường đi của LISP.
    Code:
    R111-Host1#[COLOR=#FF0000][B]traceroute 192.168.7.1 source 192.168.1.1 [/B][/COLOR]
    Type escape sequence to abort.
    Tracing the route to 192.168.7.1
    VRF info: (vrf in name/id, vrf out name/id)
      [COLOR=#FF0000] 1 172.16.1.2 0 msec 0 msec 0 msec
       2 10.0.2.1 1 msec 7 msec 7 msec
       3 10.0.9.2 1 msec 1 msec 0 msec
       4 172.16.7.1 1 msec *  0 msec[/COLOR]
    R111-Host1#
    Chú ý rằng tất cả các hop giữa 2 LISP EID đều hiển thị. (Thông thường, các công nghệ tunnel như GRE và IPsec ẩn các thành phần trong mạng giữa 2 điểm đầu cuối đường hầm).

  • #2
    CẤU HÌNH CUỐI CÙNG CỦA CÁC ROUTER



    R111-Host1:
    Code:
    [SPOILER]
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R111-Host1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    no ip domain lookup
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback1
     no shutdown
     ip address 192.168.1.1 255.255.255.255
     ipv6 address 2001:DB8:A:1::1/128
     ipv6 ospf 6 area 0
    !
    interface Loopback2
     no shutdown
     ip address 192.168.1.2 255.255.255.255
     ipv6 address 2001:DB8:A:1::2/128
     ipv6 ospf 6 area 0
    !
    interface Loopback3
     no shutdown
     ip address 192.168.1.3 255.255.255.255
     ipv6 address 2001:DB8:A:1::3/128
     ipv6 ospf 6 area 0
    !
    interface Loopback4
     no shutdown
     ip address 192.168.1.4 255.255.255.255
     ipv6 address 2001:DB8:A:1::4/128
     ipv6 ospf 6 area 0
    !
    interface Ethernet0/0
     no shutdown
     ip address 172.16.1.1 255.255.255.0
     ip ospf 1 area 0
     ipv6 address 2001:DB8:A:2::1/64
     ipv6 ospf 6 area 0
    !
    interface Ethernet0/1
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    router ospf 1
     network 192.168.1.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    ipv6 router ospf 6
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]
    R112-xTR:
    Code:
    [SPOILER]
    !
    ! Last configuration change at 22:33:04 EET Sat Oct 26 2019
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R112-xTR
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    no ip domain lookup
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     no shutdown
     ip address 192.168.1.254 255.255.255.255
     ipv6 address 2001:DB8:A:1::254/128
     ipv6 ospf 6 area 0
    !
    interface LISP0
     no shutdown
    !
    interface Ethernet0/0
     no shutdown
     ip address 172.16.1.2 255.255.255.0
     ip ospf 1 area 0
     ipv6 address 2001:DB8:A:2::2/64
     ipv6 ospf 6 area 0
    !
    interface Ethernet0/1
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet1/0
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet1/1
     no shutdown
     ip address 10.0.1.2 255.255.255.252
    !
    interface Ethernet1/2
     no shutdown
     ip address 10.0.2.2 255.255.255.252
    !
    interface Ethernet1/3
     no shutdown
     no ip address
     shutdown
    !
    router lisp
     locator-set SITE1
      10.0.1.2 priority 1 weight 1
      exit
     !
     eid-table default instance-id 0
      database-mapping 192.168.1.0/24 locator-set SITE1
      exit
     !
     loc-reach-algorithm rloc-probing
     ipv4 itr map-resolver 10.0.100.2
     ipv4 itr
     ipv4 etr map-server 10.0.100.2 key SITE1KEY
     ipv4 etr
     exit
    !
    router ospf 1
     default-information originate
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 10.0.1.1
    ip route 0.0.0.0 0.0.0.0 10.0.2.1
    !
    ipv6 route ::/0 2001:DB8:2:3::1
    ipv6 router ospf 6
     default-information originate always
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]
    R113-Core:
    Code:
    [SPOILER]
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R113-Core
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    no ip domain lookup
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback1
     no shutdown
     ip address 10.200.1.1 255.255.255.0
    !
    interface Ethernet0/0
     no shutdown
     description Connection to MSMR
     ip address 10.0.100.1 255.255.255.252
     ipv6 address 2001:DB8:3:4::1/64
    !
    interface Ethernet0/1
     no shutdown
     description Connection to PxTR
     ip address 10.0.101.1 255.255.255.252
     ipv6 address 2001:DB8:3:5::1/64
    !
    interface Ethernet0/2
     no shutdown
     description Connection to LISP Site 2 (RTR 116)
     ip address 10.0.9.1 255.255.255.252
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet1/0
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet1/1
     no shutdown
     description Connection to LISP Site 1 (RTR 112)
     ip address 10.0.1.1 255.255.255.252
    !
    interface Ethernet1/2
     no shutdown
     description Connection to LISP Site 1 (RTR 112)
     ip address 10.0.2.1 255.255.255.252
    !
    interface Ethernet1/3
     no shutdown
     no ip address
     shutdown
    !
    router bgp 3
     bgp asnotation dot
     bgp log-neighbor-changes
     neighbor 10.0.101.2 remote-as 5
     neighbor 2001:DB8:3:5::2 remote-as 5
     !
     address-family ipv4
      neighbor 10.0.101.2 activate
      no neighbor 2001:DB8:3:5::2 activate
     exit-address-family
     !
     address-family ipv6
      neighbor 2001:DB8:3:5::2 activate
     exit-address-family
    !
    ip forward-protocol nd
    !
    ip bgp-community new-format
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]
    R114-MSMR:
    Code:
    [SPOILER]
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R114-MSMR
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    no ip domain lookup
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
     no shutdown
     ip address 10.0.100.2 255.255.255.252
     ipv6 address 2001:DB8:3:4::2/64
    !
    interface Ethernet0/1
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    router lisp
     site site1
      description LISP Site 1 - GOLD Lab
      authentication-key SITE1KEY
      eid-prefix 192.168.1.0/24
      eid-prefix 2001:DB8:A::/48
      exit
     !
     site site2
      description Site 2 - GOLD Lab
      authentication-key SITE2KEY
      eid-prefix 192.168.7.0/24
      eid-prefix 2001:DB8:B::/48
      exit
     !
     ipv4 map-server
     ipv4 map-resolver
     ipv6 map-server
     ipv6 map-resolver
     exit
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 10.0.100.1
    !
    ipv6 route ::/0 2001:DB8:3:4::1
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]
    R115-PxTR:
    Code:
    [SPOILER]
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R115-PxTR
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    no ip domain lookup
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface LISP0
     no shutdown
    !
    interface Ethernet0/0
     no shutdown
     ip address 10.0.101.2 255.255.255.252
     ipv6 address 2001:DB8:3:5::2/64
    !
    interface Ethernet0/1
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    router lisp
     eid-table default instance-id 0
      ipv4 route-import map-cache static route-map EID-space
      ipv6 route-import map-cache static route-map EID-space
      exit
     !
     ipv4 map-request-source 10.0.101.2
     no ipv4 map-cache-persistent
     ipv4 map-cache-limit 100000
     ipv4 proxy-etr
     ipv4 proxy-itr 10.0.101.2 2001:DB8:3:5::2
     ipv4 itr map-resolver 10.0.100.2
     ipv6 map-request-source 2001:DB8:3:5::2
     no ipv6 map-cache-persistent
     ipv6 map-cache-limit 100000
     ipv6 proxy-etr
     ipv6 proxy-itr 2001:DB8:3:5::2 10.0.101.2
     ipv6 itr map-resolver 10.0.100.2
     exit
    !
    router bgp 5
     bgp asnotation dot
     bgp log-neighbor-changes
     neighbor 10.0.101.1 remote-as 3
     neighbor 2001:DB8:3:5::1 remote-as 3
     !
     address-family ipv4
      redistribute static route-map pop-EID
      neighbor 10.0.101.1 activate
      no neighbor 2001:DB8:3:5::1 activate
     exit-address-family
     !
     address-family ipv6
      redistribute static route-map pop-EID
      neighbor 2001:DB8:3:5::1 activate
     exit-address-family
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 10.0.101.1
    ip route 192.168.0.0 255.255.0.0 Null0 tag 111
    !
    ipv6 route 2001:DB8:A::/47 Null0 tag 111
    ipv6 route ::/0 2001:DB8:3:5::1
    !
    route-map EID-space permit 10
     match tag 111
    !
    route-map pop-EID permit 10
     match tag 111
     set origin igp
     set community 7274501
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]
    R116-xTR:
    Code:
    [SPOILER]
    !
    ! Last configuration change at 22:35:11 EET Sat Oct 26 2019
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R116-xTR
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     no shutdown
     ip address 192.168.7.254 255.255.255.255
     ipv6 address 2001:DB8:B:1::254/128
    !
    interface LISP0
     no shutdown
    !
    interface Ethernet0/0
     no shutdown
     description Conn to Inside (hosts)
     ip address 172.16.7.2 255.255.255.0
     ip ospf 1 area 0
     ipv6 address 2001:DB8:B:2::2/64
     ipv6 ospf 6 area 0
    !
    interface Ethernet0/1
     no shutdown
     description Conn to CORE (RLOC for LISP)
     ip address 10.0.9.2 255.255.255.252
    !
    interface Ethernet0/2
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    router lisp
     locator-set SITE2
      10.0.9.2 priority 1 weight 1
      exit
     !
     eid-table default instance-id 0
      database-mapping 192.168.7.0/24 locator-set SITE2
      exit
     !
     ipv4 itr map-resolver 10.0.100.2
     ipv4 itr
     ipv4 etr map-server 10.0.100.2 key SITE2KEY
     ipv4 etr
     exit
    !
    router ospf 1
     default-information originate always
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 10.0.9.1
    !
    ipv6 router ospf 6
     router-id 172.16.7.2
     default-information originate always
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]
    R117-Host2:
    Code:
    [SPOILER]
    !
    version 15.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R117-Host2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    clock timezone EET 2 0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    !
    !
    !
    !
    !
    !
    !
    !
    
    
    !
    !
    !
    !
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy
    !
    !
    ! 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback1
     no shutdown
     ip address 192.168.7.1 255.255.255.255
     ipv6 address 2001:DB8:B:1::1/128
     ipv6 ospf 6 area 0
    !
    interface Loopback2
     no shutdown
     ip address 192.168.7.2 255.255.255.255
     ipv6 address 2001:DB8:B:1::2/128
     ipv6 ospf 6 area 0
    !
    interface Loopback3
     no shutdown
     ip address 192.168.7.3 255.255.255.255
     ipv6 address 2001:DB8:B:1::3/128
     ipv6 ospf 6 area 0
    !
    interface Loopback4
     no shutdown
     ip address 192.168.7.4 255.255.255.255
     ipv6 address 2001:DB8:B:1::4/128
     ipv6 ospf 6 area 0
    !
    interface Ethernet0/0
     no shutdown
     ip address 172.16.7.1 255.255.255.0
     ip ospf 1 area 0
     ipv6 address 2001:DB8:B:2::1/64
     ipv6 ospf 6 area 0
    !
    interface Ethernet0/1
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no shutdown
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no shutdown
     no ip address
     shutdown
    !
    router ospf 1
     network 192.168.7.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    ipv6 router ospf 6
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
     transport input none
    !
    !
    end
    [/SPOILER]

    Comment

    Working...
    X