• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

ROUTE (642-902): Redistribute Questions

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ROUTE (642-902): Redistribute Questions

    Question 1

    Refer to the exhibit. Which statement is true?
hostname RAR1
!

!
router bgp 100
neighbor 172.16.1.2 remote-as 200
neighbor 172.16.1.2 distribute-list 101 in
!
access-list 101 permit ip 10.10.0.0 0.0.31.255 0.0.0.0 0.0.0.0
A. Router RAR1 will accept only route 10.10.0.0/19 from its BGP neighbor.
B. Router RAR1 will send only route 10.10.0.0/19 to its BGP neighbor.
C. Only traffic with a destination from 10.10.0.0/19 will be permitted.
D. Only traffic going to 10.10.0.0/19 will be permitted.

Answer: A


Question 2

Refer to the exhibit. Which three statements accurately describe the result of applying the exhibited route map? (Choose three)
router eigrp 1
redistribute ospf 1 route-map ospf-to-eigrp
default-metric 20000 2000 255 1 1500
!
!
route-map ospf-to-eigrp deny 10
match tag 6
match route-type external type-2
!
route-map ospf-to-eigrp permit 20
match ip address prefix-list pfx
set metric 40000 1000 255 1 1500
!
route-map ospf-to-eigrp permit 30
set tag 8
A. The map prohibits the redistribution of all type 2 external OSPF routes with tag 6 set.
B. The map prohibits the redistribution of all type 2 external OSPF routes.
C. The map redistributes into EIGRP all routes that match the pfx prefix list and the five metric values 40000, 1000, 255, 1, and 1500.
D. The map prohibits the redistribution of all external OSPF routes with tag 6 set.
E. All routes that do no match clauses 10 and 20 of the route map are redistributed with their tags set to 8.
F. The map permits the redistribution of all type 1 external OSPF routes.

Answer: A E F

Explanation

In the route-map:

route-map ospf-to-eigrp deny 10
match tag 6
match route-type external type-2

The deny clause rejects route matches from redistribution. If several match commands are present in a clause, all must succeed for a given route in order for that route to match the clause (in other words, the logical AND algorithm is applied for multiple match commands). In this question, both the “match tag 6″ and “match route-type external type-2″ must be matched for this route to be denied -> A is correct.
If a match command is not present, all routes match the clause. In this question, all routes that reach clause 30 match and their tags are set to 8 -> E is correct.
If a route is not matched with clause 10 or 20 then it will be matched with clause 30 for sure -> F is correct.
Note: Route-maps that are applied to redistribution behave the same way as ACLs: if the route does not match any clause in a route-map then the route redistribution is denied, as if the route-map contained deny statement at the end.


Question 3

Refer to the exhibit. On the basis of the information in the exhibit, which two statements are true? (Choose two)
A. The output was generated by entering the show ip bgp command on the ISP router.
B. The output was generated by entering the show ip bgp command on the SanJose1 router.
C. The serial0/0/1 interface on the ISP router has been configured with the set metric 50 command.
D. The serial 0/0/1 Interface on the ISP router has been configured with the set metric 75 command.
E. When traffic is sent from the ISP to autonomous system 64512, the traffic will be forwarded to SanJose1 because of the lower MED value of SanJose1.
F. When traffic is sent from the ISP to autonomous system 64512, the traffic will be forwarded to SanJose2 because of the higher MED value of SanJose2.

Answer: A E

Explanation

From the output, we notice that the “local router ID” is 192.168.100.1 which is an interface on ISP router -> A is correct.
The show ip bgp command is used to display entries in the Border Gateway Protocol (BGP) routing table
Multi-Exit Discriminator (MED) is used when we have multiple entry points (connections) to another AS. A lower MED value is preferred over a higher value. Notice that the comparison between the MED only occurs if the first AS is the same in two (or more) paths. In this question, the first AS is 64512 which is the same -> the comparison can occur.

From the output, we learn that ISP router is receiving the 172.16.0.0 network from SanJose1 (192.168.1.6) with a metric of 50 and from SanJose2 (192.168.1.2) with a metric of 75. Also note that BGP has chosen the best path 192.168.1.6 to the 172.16.0.0 network (the “>” indicates it is the best path). The Weight, Local Preference (LocPrf) and AS-Path values between two next hops (192.168.1.2 & 192.168.1.6) are the same so we can deduce the traffic from ISP is sent from the ISP to SanJose1 because of the lower MED value.
Note: An entry of 0.0.0.0 in the “Next Hop” indicates that the router has some non-BGP routes to this network.

Question 4

Refer to the exhibit. Routers R1 and R2 have been configured to operate with OSPF. Routers R1 and R3 have been configured to operate with RIP. After configuring the redistribution between OSPF and RIP on R1, no OSPF routes are distributed into RIP. What should be done to correct this problem?
A. The redistribution command should be reentered with the match route-type parameter included.
B. The redistribution command should be reentered with the route-map map-tag parameter included.
C. The redistribution command should be reentered with the metric metric-value parameter included.
D. Routes will first need to be distributed into another protocol, and then into RIP.


Answer: C

Explanation

Notice that RIP metric is based on hop count only, and the maximum valid metric is 15. Anything above 15 is considered infinite. By default, when no metric is assigned when redistributing from EIGRP, OSPF, IS-IS, BGP into RIP, the default metric will be infinite. Therefore we must define a metric that is understandable to the receiving protocol. Usually, we should use a small value (like 1, 2, 3) so that after redistributing, that route can be advertised through many routers (because the limit is 15).


Question 5

router eigrp 123
redistribute ospf 123
network 116.16.35.0 0.0.0.255
network 130.130.0.0
auto-summary
!
router ospf 123
log-adjacency-changes
network 116.16.34.0 0.0.0.255 area 0
neighbor 116.16.34.4
Refer to the exhibit. Why are the EIGRP neighbors for this router not learning the routes redistributed from OSPF?
A. Redistribution must be enabled mutually (in both directions) to work correctly.
B. Auto-summary causes the OSPF routes redistributed into EIGRP to be summarized; thus the OSPF network 116.16.34 is summarized to 116.34.0.0, which is already covered by the EIGRP protocol.
C. Default metrics are not configured under EIGRP.
D. Both routing protocols must have unique autonomous system numbers for redistribution to function correctly.

Answer: C

Explanation

Same as RIP, when redistribute into EIGRP from OSPF, the default metric is infinite -> We must set a seed metric when redistributing into EIGRP. Below lists the default seed metrics when redistributing from a routing protocol into another:

Redistributed Protocol Default Seed Metric
RIP Infinity
IGRP/EIGRP Infinity
OSPF 20 for all (except for BGP, which is 1)
BGP is set to IGP metric value
Question 6

If a metric is not specified for routes that are redistributed into OSPF, the default metric that is assigned to the routes is 20, except for redistributed BGP routes. What is the metric that is assigned to redistributed BGP routes?

A. 0
B. 1
C. 10
D. 200

Answer: B


Question 7

During a redistribution of routes from OSPF into EIGRP, an administrator notices that none of the OSPF routes are showing in EIGRP. What are two possible causes? (Choose two)

A. incorrect distribute lists have been configured
B. missing ip classless command
C. CEF not enabled
D. no default metric configured for EIGRP

Answer: A D

Explanation

An incorrect distribute list can filter out updates therefore none of the OSPF routes are showing in EIGRP -> A is correct.
The default metric when redistributing into EIGRP is infinite so we must specify a seed metric for EIGRP to work with -> D is correct.

Question 8


During the redistribution process configured on RTA, some of the EIGRP routes, such as 10.1.1.0/24 and 10.2.2.0/24, are not being redistributed into the OSPF routing domain. Which two items could be a solution to this problem? (Choose two)
A. Change the metric-type to 2 in the redistribute command.
B. Configure the redistribute command under router eigrp 1 instead.
C. Change the EIGRP AS number from 100 to 1 in the redistribute command.
D. Add the subnets option to the redistribute command.
E. Change the metric to ah EIGRP compatible metric value (bandwidth, delay, reliability, load, MTUs) in the redistribute command.

Answer: C D

Explanation

The AS of EIGRP in the output above is not correct and we need to fix it into “eigrp 1″. Also, some of EIGRP routes, such as 10.1.1.0/24 and 10.2.2.0/24 are subnets so we must use the keyword “subnets” so that OSPF can see these routes. The full commands should be:
router ospf 1
redistribute eigrp 1 metric 20 metric-type 1 subnets


Question 9

You want the redistributed EIGRP AS 10 routes to have an administrative distance of 121 when they appear as RIP routes in the routing table of A1. Which command should you use on a router to accomplish this goal?
A. redistribute eigrp 10 metric 121
B. redistribute rip metric 121
C. default-metric 121
D. distance 121 10.1.1.6 0.0.0.0

Answer: D


Question 10

Refer to the exhibit. Which three commands should be used on router B1 to redistribute the EIGRP AS 10 routes into RIP? (Choose three)

A. router rip
B. router eigrp 10
C. redistribute eigrp 10
D. redistribute rip
E. default-metric 10000 100 255 1 1500
F. default-metric 5

Answer: A C F


Question 11

Refer to the exhibit and the partial configuration on router R2. On router R4 all RIP routes are redistributed into the OSPF domain. A second redistribution is configured on router R2 using a route map. Based on the configuration on router R2, which EIGRP external routes will be present in the routing table of R1?
A. the routes originating from the RIP routing domain
B. the routes originating from the OSPF stub area
C. all OSPF inter and intra-area routes
D. all routes originating from RIP and OSPF routing domains

Answer: A

Explanation

R2 sees the routes from RIP domain as external routes while it sees the routes from OSPF Stub Area as internal routers. From the output we learn that the “route-type external” is redistributed from OSPF to EIGRP (via route-map ABC) so we will see the routes from the RIP domain (external) in the routing table of R1 -> A is correct.
In the case we want to redistribute routes from OSPF Stub Area (Area 1) to EIGRP we need to use the “match route-type internal” command instead.


Question 12

Refer to the exhibit. Router B is performing bidirectional redistribution between EIGRP and OSPF. The network 10.100.1.0/24 should not be reachable from the 10.100.9.0/24 network. However, it needs to be reachable from any network within the EIGRP domain. All other networks should be seen in both domains.
Which change to router B would accomplish these goals?
A. Under the EIGRP process, insert the distribute-list block_net_1 out ospf 1 command.
B. Under the OSPF process, insert the distribute-list block_net_1 in serial1/0 command.
C. Under the EIGRP process, insert the distribute-list block_net_1 in serial1/0 command.
D. Under the OSPF process, insert the distribute-list block_net_1 out eigrp 1 command.

Answer: D

Explanation

The network 10.100.1.0/24 should not be reachable from network 10.100.9.0/24 -> we need to filter updates from EIGRP to OSPF so that the routing table of router C doesn’t have network 10.100.1.0/24 -> we need to filter it under OSPF process and the direction should be out of router B -> D is correct.


Question 13

Which three route filtering statements are true? (Choose three)
A. After the router rip and passive-interface s0/0 commands have been issued, the s0/0 interface will not send any RIP updates, but will receive routing updates on that interface.
B. After the router eigrp 10 and passive-interface s0/0 commands have been issued, the s0/D interface will not send any EIGRP updates, but will receive routing updates on that interface
C. After the router ospf 10 and passive-interface s0/0 commands have been issued , the s0/0 interface will not send any OSPF updates, but will receive routing updates on that interface
D. When you use the passive-interface command with RIPv2, multicasts are sent out the specified interface
E. When you use the passive-interface command with EIGRP, hello messages are not sent out the specified interface
F. When you use the passive-interface command with OSPF, hello messages are not sent out the specified interface

Answer: A E F
Explanation

The “passive-interface …” command in EIGRP or OSPF will shut down the neighbor relationship of these two routers (no hello packets are exchanged) -> E, F are correct.

In RIP, this command will not allow sending multicast updates via a specific interface but will allow listening to incoming updates from other RIP speaking neighbors. This means that the router will still be able to receive updates o­n that passive interface and use them in its routing table -> A is correct.

Question 14

Refer to the exhibit. The routing protocols EIGRP and OSPF have been configured as indicated in the exhibit. Given the partial configuration of router R2, which network will be present in the routing table of R4?

A. Network A
B. Network B
C. Network A and Network B
D. neither Network A nor Network B

Answer: B

Explanation

From the show running-config output, we learn that only OSPF is redistributed into EIGRP AS 100 so only network B will be present in the routing table of R4. Notice that we must specify the metric when redistributing into EIGRP so that it can work well.

Question 15

Refer to the exhibit. Which three statements are true? (Choose three)
A. On the routing table of R4, the 10.1.1.0/24 route appears as an O E2 route.
B. On R4, the 172.16.1.0/24 route has a metric of 20.
C. The R3 S0/0 interface should not need the no ip split-horizon eigrp 1 configuration command for the 172.16.1.0/24 route to appear in the routing table of R2 as an D EX route.
D. The administrative distance of the 172.16.1.0/24 route in the routing table of R3 is 170.
E. On R5, the 4.0.0.0/8 route will have an administrative distance of 120 and a hop count of 6.


Answer: A B D

Explanation

When redistributing into OSPF, the default route type is E2 -> A is correct. Notice that the cost of E2 type is always the cost of external route only.
Also, the default seed metric when redistributing into OSPF is always 20 (except for BGP, which is 1) -> B is correct.
When redistributing into EIGRP, the external EIGRP routes have an administrative distance of 170 by default -> D is correct.

Question 16

Refer to the exhibit. Looking at the topology diagram and the partial router configurations shown, which statement is true?

A. A routing loop will occur due to mutual route redistribution occurring on R1 and R2.
B. Suboptimal routing will occur due to mutual route redistribution occurring on R1 and R2.
C. Additional route filtering configurations using route maps and ACLs are required on the R1 and R2 routers to prevent routing loops.
D. R2 will not be able to redistribute the EIGRP subnets into OSPF, because R2 is missing the default seed metric for OSPF.
E. The 10.1.1.0/24 subnet will appear as 10.0.0.0/8 in the R5 routing table.

Answer: E

Explanation

RIPv1 is a classful routing protocol so the subnet 10.1.1.0/24 will be summarized to 10.0.0.0/8 in the R5 routing table. If we use RIPv2 on R1, R5 and use the “no auto-summary” command on R1 then the 10.1.1.0 subnet will appear in the routing table of R5. Notice that even if the “auto-summary” command is configured under “router eigrp 1″ of R1 but when redistributing into another routing protocol EIGRP still advertises the detailed network.

Question 17

Refer to the exhibit. R1 and R2 have been configured to share routing information via EIGRP. What will be the result of the configuration section shown for R2?

A. Any routes learned by R2 from the interface tied to the 172.16.0.0 network will not be advertised to neighbors on the 192.168.2.0 network.
B. Only routes learned by R2 from the interface tied to the 172.16.0.0 network will be advertised to neighbors on the 192.168.2.0 network.
C. Only the 172.16.0.0 network will be advertised to neighbors on the 192.168.2.0 network.
D. All networks, except the 172.16.0.0 network will be advertised to neighbors on the 192.168.2.0 network.

Answer: C


Question 18

Refer to the exhibit. EIGRP has been configured on router D. Router C is performing mutual redistribution between EIGRP and OSPF. While verifying that the redistribution is functioning properly, you discover that while router C has all of the EIGRP routes in its routing table, router A does not have any routes from the EIGRP domain. What on router C may be the cause of the problem?

A. The no auto-summary command needs to be added under router eigrp 1.
B. The subnets keyword was not included in the redistribute command under router ospf 1.
C. The metric specified for the redistributed EIGRP routes is too large; making the EIGRP routes unreachable by router A.
D. The defauft-information originate command needs to be added under router ospf 1.
E. The administrative distance of either OSPF or EIGRP must be changed so that EIGRP has a higher administrative distance than OSPF.

Answer: B

Explanation

If we don’t use the “subnets” keyword when redistributing routes learned from another routing process into OSPF, only classful routes will be redistributed. This is an important thing to remember when redistributing into OSPF -> B is correct.

Question 19


You have implemented mutual route redistribution between OSPF and EIGRP on a border router. When checking the routing table on one of the EIGRP routers within the EIGRP routing domain, you are seeing some, but not all of the expected routes. What should you verify to troubleshoot this problem?
A. The border router is using a proper seed metric for OSPF.
B. The border router is using a proper seed metric for EIGRP.
C. The administrative distance is set for OSPF and EIGRP.
D. The missing OSPF routes are present in the routing table of the border router.
E. The subnet keyword on the border router in the redistribute OSPF command.

Answer: D

Explanation

We are checking the routing table on EIGRP routers not OSPF so we don’t need to check the seed metric for OSPF. Besides OSPF doesn’t need to specify seed metric as all external routes get a default metric of 20 (except for BGP, which is 1) -> A is not correct.
We must specify seed metrics when redistributing into EIGRP (and RIP). If not all the redistributed routes will not be seen but the question says only some routes are missing -> B is not correct.
The default administrative distance for external routes redistributed into EIGRP is 170 so we don’t need to set it -> C is not correct.
The sunbet keyword is only used when redistributing into OSPF, not to other routing protocols -> E is not correct.
We should check the routing table of the border router to see the missing OSPF routes are there or not. An incorrect distribute-list can block some routes and we can’t see it in other EIGRP routers -> D is correct.

Question 20

Refer to the exhibit. Which two statements are correct regarding the routes to be redistributed into OSPF? (Choose two)

A. The network 192.168.1.0 will be allowed and assigned a metric of 100.
B. The network 192.168.1.0 will be allowed and assigned a metric of 200.
C. All networks except 10.0.0.0/8 will be allowed and assigned a metric of 200.
D. The network 172.16.0.0/16 will be allowed and assigned a metric of 200.
E. The network 10.0.10.0/24 will be allowed and assigned a metric of 200.


Answer: A D

Explanation

These rules apply when using route-map with an access-list:
* If you use an ACL in a route-map permit clause, routes that are permitted by the ACL are redistributed.
* If you use an ACL in a route-map deny clause, routes that are permitted by the ACL are not redistributed.
* If you use an ACL in a route-map permit or deny clause, and the ACL denies a route, then the route-map clause match is not found and the next route-map clause is evaluated.
And in each route-map:
* Multiple match criteria in the same line use a logical OR
* Each vertical match uses a logical AND
Therefore in this question, the networks in the access lists 10 and 20 (10.0.10.0/24 & 192.168.1.0/24) will be permitted while the network in access list 30 (10.0.0.0/8) will be denied.
Notice that there is no “match” line in the clause 30 so all networks that are not matched with clause 10 & 20 will be matched in the clause 30 and will be set a metric of 200, type 2 -> answer D is correct.
In this question please don’t be confused between the route-map clause number (sequence number) and the access-list number. The “match ip address” specifies which access lists are matched. The route-map clause number only uses to specify the order in which the clauses are executed.


Question 21

Given the accompanying output, which additional command is needed to redistribute IGRP into EIGRP?
Router eigrp 123
Network 10.10.10.0
No auto-summary
!
Router igrp 123
Network 172.16.0.0
Network 172.17.0.0
A. Under the router igrp mode add redistribute eigrp 123
B. Under the router eigrp mode add redistribute igrp 123
C. Under the router eigrp mode add redistribute igrp 123 subnets
D. None, EIGRP and IGRP are automatically redistributed in this instance.

Answer: D

Explanation

If IGRP and EIGRP use the same Autonomous System (AS) then redistribution occurs automatically. In this case both IGRP & EIGRP use the same AS 123 so they are automatically redistributed.
If IGRP and EIGRP use different AS numbers then redistribution must be done manually.

Question 22

Study the exhibit carefully. Router R1 is connected to networks 172.16.1.0/26 and 172.16.1.64/27. Based on the partial output in the exhibit, which description is correct?

A. Router R1 should be reconfigured with an ACL instead of an ip prefix-list command.
B. Router R1 will advertise both routes.
C. Router R1 will deny the 172.16.1.0/27 route while permitting the 172.16.1.0/26 route to be advertised.
D. Router R1 will deny the 172.16.1.0/26 route while permitting the 172.16.1.64/27 route to be advertised.


Answer: C

Explanation

Prefix lists are configured with permit or deny keywords to either permit or deny the prefix based on the matching condition. A prefix list consists of an IP address and a bit mask. The IP address can be a classful network, a subnet, or a single host route. The bit mask is entered as a number from 1 to 32.
Prefix lists are configured to match an exact prefix length or a prefix range. The ge and le keywords are used to specify a range of the prefix lengths to match, providing more flexible configuration than can be configured with just the network/length argument. The prefix list is processed using an exact match when neither ge nor le keyword is entered.
Therefore in this case the exact 172.16.1.0/26 network is permitted while other networks are denied.


Question 23

Refer to the exhibit. The partial configuration for an OSPF ASBR and an Area 0 ABR is shown. Assume the OSPF configurations throughout the network are operable. Which statement about these configurations is true?


A. The ASBR route-maps are basically useless, because there are no deny prefix-lists.
B. LSA Type 5s will not be received by the ABR from the ASBR.
C. The OSPF backbone will not learn any RFC 1918 addresses.
D. The matched prefix-list addresses will be given a metric of 255, which is essentially unreachable.

Answer: C
Explanation

The ASBR accepts RFC 1918 addresses and set these networks to “tag 255″ but when advertising into Area 0, the ABR Area 0 filters out these networks because they match “tag 255″ so the OSPF backbone will not learn any RFC 1918 addresses.

Note that if you use an ACL in a route-map deny clause, routes that are permitted by the ACL are not redistributed.
All the networks with “tag 255″ are blocked by the clause 10 while all other networks are permitted by the clause 20 of the route-map (if a match command is not present, all routes match the clause).
Note:
RFC 1918 addresses include:
+ Class A: 10.0.0.0 – 10.255.255.255 (10/8 prefix)
+ Class B: 172.16.0.0 – 172.31.255.255 (172.16/12 prefix)
+ Class C: 192.168.0.0 – 192.168.255.255 (192.168/16 prefix)

Question 24

A network administrator is troubleshooting a redistribution of RIP routes into OSPF. Given the exhibited configuration commands, which statement is true?
rooter rip
network 10.0.0.0
!
router ospf 5
network 172.10.0.0 0.0.255.255 area 0
redistribute rip
A. Redistributed routes will be tagged as external type 1 (E1) with a metric of 30.
B. Redistributed routes will be tagged as external type 2 (E2) with a metric of 20.
C. Redistributed routes will maintain their original RIP routing metric.
D. Redistributed routes will have a default metric of 0 and will be treated as unreachable and not advertised.
E. Redistributed routes will have a default metric of 0 but will not be treated as reachable and will be advertised.

Answer: B

Explanation

By default, all routes redistributed into OSPF will be tagged as external type 2 (E2) with a metric of 20, except for BGP routes (with a metric of 1).
Note: The cost of a type 2 route is always the external cost, irrespective of the interior cost to reach that route. A type 1 cost is the addition of the external cost and the internal cost used to reach that route.


Question 25


Refer to the exhibit. On the basis of the partial configuration, which two statements are correct? (Choose two)
!
router rip
distribute-list 2 out ethernet 0
distribute-list 1 out
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 2 permit 10.0.1.0 0.0.0.255
!
A. Only routes matching 10.0.1.0/24 will be advertised out Ethernet 0.
B. Only routes 10.0.1.0/24 will be sent out all interfaces.
C. Only routes 10.0.1.0/24 will be allowed in the routing table.
D. Only routes matching 10.0.0.0/8 will be advertised out Ethernet 0.
E. Only routes matching 10.0.0.0/8 will be advertised out interfaces other than Ethernet 0.
F. All routes will be advertised out interfaces other than Ethernet 0.

Answer: A E

Explanation

In this case, the following algorithm is used when multiple distribute-lists are used:
1. First check which interface is being sent out. If it is Ethernet 0, distribute-list 2 is applied first. If the network is denied then no further checking is done for this network. But if distribute-list 2 permits that network then distribute-list 1 is also checked. If both distribute-lists allow that network then it will be sent out.
2. If the interface is not Ethernet 0 then only distribute-list 1 is applied.
Now let’s take some examples.
+ If the advertised network is 10.0.1.0/24, it will be sent out all interfaces, including Ethernet 0.
+ If the advertised network is 10.0.2.0/24, it will be sent out all interfaces, excepting Ethernet 0.
+ If the advertised network is 11.0.0.0/8, it will be dropped.
Note: It is possible to define one interface-specific distribute-list per interface and one protocol-specific distribute-list for each process/autonomous-system.


Question 26

Refer to the exhibit. Examine the partial configuration and the routing table excerpt. Which routes would be redistributed into OSPF area 1?


A. 10.10.10.16/28 only
B. 10.10.10.16/28 and 10.10.10.64/26
C. 10.10.10.16/28, 10.10.10.64/26, and 172.16.10.0/24
D. 10.10.10.64/26 only

Answer: B (but in the exam you should choose D)

Explanation

The network 172.16.10.0/24 belongs to OSPF (we know from the “network 172.16.0.0 0.0.255.255 area 1″ command) so it will not be redistributed.
When using the “subnets” keyword, all the connected networks will be redistributed so 10.10.10.16/28 & 10.10.10.64/26 will be redistributed, too.

Therefore the correct answer should be B but in the exam you should choose D. Maybe it is a mistake of Cisco.

Question 27

Refer to the exhibit. A partial routing configuration is shown. Complete the configuration so that only the default-network is redistributed from EIGRP 190 into EIGRP 212. Which ACL statement completes the configuration correctly?
router eigrp 190
redistribute eigrp 212
network 192.0.0.0 0.0.0.3
!
router eigrp 212
redistribute eigrp 190 route-map default_route
network 212.50.185.96 0.0.0.31
!
route-map defau1t_route permit 10
match ip address 100
A. access-list 100 permit ip 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0
B. access-list 100 permit ip host 0.0.0.0 any
C. access-list 100 permit ip any host 0.0.0.0
D. A default-network cannot be redistributed between routing processes.

Answer: C
Explanation

The command “access-list 100 permit ip any host 0.0.0.0″ means permit any source address with the destination of 0.0.0.0/0, which is the default route
Note:
any equals 0.0.0.0 255.255.255.255
host 0.0.0.0 equals 0.0.0.0 0.0.0.0

Question 28

Refer to the exhibit. Router B and router C are performing mutual redistribution between OSPF and EIGRP, and their default metrics are configured the same. Router D has equal cost paths to networks where both paths are not really equal cost. For example, network 172.16.54.0 shows equal cost through both router B and router C, though in reality the cost is greater using router C. Other routers, though not shown, are connected to the 172.16.54.0 and 172.16.55.0 networks, and the same issues exist to those routers and the networks connected to them.
What can be done so that data will be routed along the most optimal path in the network?
A. Redistribute connected interfaces on router B and router C.
B. Set the maximum number of equal cost paths to 1 in all routers.
C. When redistributing EIGRP into OSPF, set the external metric type to type E1.
D. Adjust the default metrics in router B and router C so that the values are different in each router.
E. None of these solutions will fix the problem. Migrate to a single dynamic routing protocol.

Answer: E

Explanation

Let’s discuss about answers C & D first.
From the output, we learn that all the External OSPF routes have metrics of 100 (the second parameters in [110/100]). This is not the default metric of OSPF Type 2 External route (the default value is 20) so the metrics of redistributed routes have been modified. Maybe when redistributing into OSPF, the “metric” in the “redistribute” command or the “default-metric” command was used on router B & C to assign the metric of these routes. Something like this:
router ospf 1
redistribute eigrp 1 metric 100 subnets
or
router ospf 1
…..
default-metric 100
Therefore even if we use the metric type E1 the problem still exists because the link B-D & C-D seems to have the same metric -> the total metrics remains the same -> C is not correct.
We can use route-map and set different metrics for each networks but some unshown networks will have the same issues -> D is not a good choice
So the best answer should be E.

Question 29

Refer to the exhibit. A new TAC engineer comes to you for advice. The engineer wants to configure RIPv2-OSPF two-way redistribution while avoiding routing loops. Which two additions to the router B1 configuration should the engineer make? (Choose two)

A. access-list 40 deny 172.16.1.0 0.0.0.255
access-list 40 permit any
router rip
redistribute ospf 100 metric 5
distribute-list 40 out ospf 100
B. ip prefix-list rip_routes permit 172.16.1.16/25 ge 26 le 28
route-map redis-ospf deny 10
match ip address prefix-list rip_routes
router rip
redistribute ospf 10 route-map redis-ospf subnets
C. ip prefix-list rip-to-ospf permit 10.1.1.8/25 ge 26 le 28
route-map redis-rip deny 20
match ip address prefix-list rip-to-ospf
router ospf 100
redistribute rip route-map redis-rip subnets
D. access-list 15 deny 10.1.1.0 0.0.0.63
access-list 15 permit any
route-map redis-rip deny 10
match ip address 15
route-map redis-rip permit 20
router ospf 100
redistribute rip route-map redis-rip subnets

Answer: A D

Explanation

B1 is not the only router that redistributes between RIP & OSPF. The “small” router below B1 can be configured for this task too so B1 can try to redistribute networks advertised by that “small” router again. Therefore it is necessary to filter out networks that have been advertised by the “small” router. For example, we need to prevent network 172.16.1.0/24 from advertised back into RIPv2 or network 10.1.1.0/26 from advertised back into OSPF. Notice that all networks in OSPF domain (including 10.1.1.8/30, 10.1.1.12/30, 10.1.1.48/28, 10.1.1.32/28) can be summarized as 10.1.1.0/26 and all networks in RIP domain (including 172.16.1.24/30, 172.16.1.20/30, 172.16.1.32/28, 172.16.1.48/28) can be summarized as 172.16.1.0/24 -> answers A & D are correct.
In answer B, the command “ip prefix-list rip_routes permit 172.16.1.16/25 ge 26 le 28″ means:
+ First check the first 25 bits of the address -> this will allow addresses from 172.16.1.0 to 172.16.1.127
+ If those match then check the subnet mask, which in this case can be GREATER THAN or EQUAL to 26 bits & LESS THAN or EQUAL to 28 bits -> meaning that /26, /27, /28 subnet masks would match.
For example, networks 172.16.1.0/26; 172.16.1.16/28 would match (but notice networks 172.16.1.0/25; 172.16.1.128/26 wouldn’t).
In the “ip prefix-list rip_routes permit 172.16.1.16/25 ge 26 le 28″, the prefix-list “rip_routes” only covers networks 172.16.1.32/28 & 172.16.1.48/28 but can’t cover networks 172.16.1.24/30 & 172.16.1.20/30. Also, the OSPF process in the “redistribute” command should be 100, not 10 -> B is not correct.
Same problem as answer B, the prefix-list in answer C can’t cover networks 10.1.1.8/30 & 10.1.1.12/30 -> C is not correct.

Question 30

Refer to the exhibit. The network administrator is trying to configure mutual redistribution between EIGRP and OSPF. Autosummarization in EIGRP 100 AS is disabled. After adding OSPF configuration to router E31, the network administrator checked the routing table of router B2, but none of the EIGRP routes appeared there.
To redistribute the EIGRP AS 100 routes into OSPF, which command should be added, or edited, on router B1 under router ospf 10?

A. redistribute eigrp 100 metric-type 1
B. redistribute eigrp 100 subnets
C. no auto-summary 10.0.0.0 255.0.0.0
D. area 0 range 10.10.0.0 255.255.0.0

Answer: B

Explanation

When redistributing into OSPF without keyword “subnets”, only classful networks will be redistributed. Classful networks here mean networks with the default major subnet masks (for example 10.0.0.0/8; 180.1.0.0/16; 200.200.200.0/24…).
In fact, the routing table on the exhibit above is not totally correct. The network 192.168.110.0/24 will be redistributed and shown in the routing table of B2 even if the keyword “subnets” is not used because it belongs to class C with the default subnet mask of class C.

To make all the networks, including subnets appear in the routing table of B2 we must use keyword “subnets” when redistributing into OSPF. This is also an important thing to remember when redistributing into OSPF.


Question 31

Refer to the exhibit. Routers R1 and R2 are running EIGRP and have converged. On the basis of the information that is presented, which statement is true?
A. All outgoing routing updates from router R1 to router R2 will be suppressed, but the inbound updates will continue to be received.
B. All incoming routing updates from R2 will be suppressed, but the outgoing updates will continue to be sent.
C. Both outgoing and incoming routing updates on R1 will be stopped because of the passive-interface Serial0/0 configuration statement.
D. Both outgoing and incoming routing updates on R1 will be permitted because the distribute-list 20 out Serial0/0 command cannot be used with association with the outgoing interface.

Answer: C

Explanation

In EIGRP (and OSPF) the passive-interface command stops sending outgoing hello packets, hence the router can not form any neighbor relationship via the passive interface. This behavior stops both outgoing and incoming routing updates -> the distribute-list has no use here.


Question 32

You have implemented mutual route redistribution between OSPF and EIGRP on a border router. When checking the routing table on one of the OSPF routers within the OSPF routing domain, you are seeing some, but not all of the expected routes.
Which two things should you verify to troubleshoot this problem? (Choose two)
A. The border router is using a proper seed metric for OSPF.
B. The border router is using a proper seed metric for EIGRP.
C. The administrative distance is set for OSPF and EIGRP.
D. The missing EIGRP routes are present in the routing table of the border router.
E. The subnet keyword on the border router in the redistribute EIGRP command.

Answer: D E

Explanation

Answer D is obvious that we should check all the routes we want to redistribute are present in the routing table of the border router. Let’s discuss about answer E.

A rule of thumb when redistributing into OSPF is we should always include the “subnets” keyword after the redistributed route. For example:
router ospf 1
redistribute eigrp 100 subnets
This keyword makes sure all of the routes, including subnets are redistributed correctly into OSPF. For example these routes are learned via EIGRP:
+ 192.168.1.0/24
+ 192.168.2.0/25
+ 192.168.3.0/26
Then without the keyword “subnets”, only 192.168.1.0/24 network is redistributed into OSPF.
For more information about “subnets” keyword, please read my Redistribute EIGRP and OSPF in GNS3 guide.

Question 33

Which three steps are most helpful in verifying proper route redistribution? (Choose three)
A. On the routers not performing the route redistribution, use the show ip route command to see if the redistributed routes show up.
B. On the ASBR router performing the route redistribution, use the show ip protocol command to verify the redistribution configurations.
C. On the ASBR router performing the route redistribution, use the show ip route command to verify that the proper routes from each routing protocol are there.
D. On the routers not performing the route redistribution, use the show ip protocols command to verify the routing information sources.
E. On the routers not performing the route redistribution, use the debug ip routing command to verify the routing updates from the ASBR.

Answer: A B C


Question 34


A router is configured for redistribution to advertise EIGRP routes into OSPF on a boundary router. Given the configuration:
router ospf 1
redistribute eigrp 1 metric 25 subnets
What is the function of the 25 parameter in the redistribute command?
A. It specifies the seed cost to be applied to the redistributed routes.
B. it specifies the administrative distance on the redistributed routes.
C. It specifies the metric limit of 25 subnets in each OSPF route advertisement.
D. It specifies a new process-id to inject the EIGRP routes into OSPF.


Answer: A


Question 35


Which command should be added to RTB under router bgp 100 to allow only the external OSPF routes to be redistributed to RTC?


A. redistribute ospf 1
B. redistribute ospf 1 match external 1
C. redistribute ospf 1 match external 2
D. redistribute ospf 1 match external 1 external 2

Answer: D


Question 36

Refer to the exhibit. Will redistributed RIP routes from OSPF Area 2 be allowed in Area 1?

A – Because Area 1 is an NSSA, redistributed RIP routes will not be allowed.
B – Redistributed RIP routes will be allowed in Area 1 because they will be changed into type 5 LSAs in Area 0 and passed on into Area 1
C – Because NSSA will discard type 7 LSAs, redistributed RIP routes will not be allowed in Area 1
D – Redistributed RIP routes will be allowed in Area 1 because they will be changed into type 7 LSAs in Area 0 and passed on into Area 1

Answer: A

Explanation

Because Area 1 is a Not-so-stubby-area (NSSA), we can inject EIGRP routes into the OSPF NSSA domain with the creation of type 7 LSAs. Redistributed RIP routes are not allowed in Area 1 because NSSA is an extension to the stub area (recall that a stub area does not accept external route unless it is connected through a ASBR, doing that will make it become a NSSA). The type 7 LSAs are converted to Type 5 LSAs when flooded into Area 0 by the ABR router.

Question 37


Look at the following exhibit. Which of the following correctly states the routes to be redistributed into OSPF? (Choose two)

A – The network 10.0.10.0/24 will be allowed and assigned a metric of 200
B – All networks except 10.0.0.0/8 will be allowed and assigned a metric of 200
C – The network 172.16.0.0/16 will be allowed and assigned a metric of 200
D – The network 192.168.1.0 will be allowed and assigned a metric of 100


Answer: C D

Explanation

Let’s analyze each route-map clause. The first one is:
route-map rip-in permit 10
match ip address 10 20
set metric 100
set metric-type type-1
If a match command refers to several objects in one command, either of them should match (the logical OR algorithm is applied). For example, in the match ip address 10 20 command, a route is permitted if it is permitted by access list 10 or access list 20 -> The networks 10.0.10.0/24 and 192.168.1.0/24 will be matched and be set metric of 100 and metric-type of Type-1. -> D is correct.
If the traffic is not matched by the first clause, the second clause is used to check:
route-map rip-in deny 20
match ip address 30
In this clause, the keyword “deny” will cause the network matched by access-list 30 to be dropped -> Network 10.0.0.0/8 will be dropped.
The last clause is:
route-map rip-in permit 30
set metric 200
set metric-type type-2
In this clause no match statement is found so all remaining routes (networks) are matched here. They will be set a metric of 200 and metric-type of Type-2. -> “network 172.16.0.0/16 will be allowed and assigned a metric of 200″ -> C is correct.
Tags:

Working...
X